Tweaking SYS.TXT for MioMap 3.3

Some of you might have tried to modify the SYS.TXT file in the MioMap (or MioMap2) directory to let MioMap behave differently. I found a post by Andy Elliott. You can find a lot of information regarding SYS.TXT. Note that the way he posted the info is not what you should put in the file. For example, if you want to show one-way street, have this in the debug section of SYS.TXT.

show_oneway=1

Ok, now here is the list of options you can do.

#==========================================================

[gps]

port=<number>

speed=<baud>

[tmc]

port=<number>

speed=<baud>

[debug]

smart_2d

value: 0,1 – Turns on Smart 2D – need explanation of this

slowsim

value: 0,1 – Whether ‘flyover’ should be quick or normal speed

loop_sim

value: 0,1 – Whether ‘flyover’ should be loop at end

show_segmentdir

value: 0,1 – Whether to show segmented directions with arrow (one-way filter lanes)

show_oneway

value: 0,1 – Whether to show one-way roads with arrow

show_uturn

value: 0,1 – Whether to show road where u-turns allowed (highlight whole road)

show_residentonly

value: 0,1 – Whether to highlight private roads (highlight whole road)

show_gps_pos

value: 0,1 – Whether to show dot where real gps position is

builtupborder

value: 0,1 – Whether to highlight country borders

showcenter

value: 0,1 – Whether to highlight country borders

show_optional_routeinfo

value: 0,1 – Whether to show additional info on route (work planned, change of the road… IS THIS TMC INFO???)

show_speed_limit

value: 0,1 – Whether to show speed limit

no_tmc

value: 0,1 – Whether to disable TMC or not

For debugging problems:

[debug]

show_mapid

value: 0,1 – Whether to numerical mapid prefix before road in popup on map

show_segmentid

value: 0,1 – Whether to numerical segmentid prefix before road in popup on map

show_roadid

value: 0,1 – Whether to numerical roadid prefix before road in popup on map

show_device_type

value: 0,1 – Whether to show message box on startup with device string

show_screensize

value: 0,1 – Whether to show message box on startup with screen

sizeshow_gx

value: 0,1 – Whether to show message box on startup with GX library info

#==========================================================

x-click-but04.gif


Find deals on Amazon.com

Mio C230 Mio GPS Garmin GPS TomTom GPS GPS and Navigation


  • Quicksilver13

    “Hi everyone

    For your test flyover you can to modify in fast or slow.

    In SYS.txt U must add this line.

    [debug]

    sim_speed_factor=1 (from 0 to 6,)

    Reboot your MIO

    If speed in low speed of the simulation equel (sample) 40 km/h (=x) where speed on road =50 km/h, then

    sim_speed_factor=0 speed of the simulation 10 km/h (0.25x)

    sim_speed_factor=1 speed of the simulation 32 km/h (1x)

    sim_speed_factor=2 speed of the simulation 64 km/h (2x)

    sim_speed_factor=3 speed of the simulation 96 km/h (3x)

    sim_speed_factor=4 speed of the simulation 128 km/h (4x)

    sim_speed_factor=5 speed of the simulation 160 km/h (5x)

    sim_speed_factor=6 speed of the simulation 200 km/h (max)

    sim_speed_factor>6 speed of the simulation 200 km/h (max)

    If speed in low speed of the simulation equel (sample) 50 km/h (=x) where speed on road =60 km/h, then

    sim_speed_factor=0 speed of the simulation 10 km/h (0.25x)

    sim_speed_factor=1 speed of the simulation 50 km/h (1x)

    sim_speed_factor=2 speed of the simulation 90 km/h (2x)

    sim_speed_factor=3 speed of the simulation 150 km/h (3x)

    sim_speed_factor=4 speed of the simulation 200 km/h (max)

    sim_speed_factor>4 speed of the simulation 200 km/h (max)

    If speed in low speed of the simulation equel (sample) 90 km/h (=x) where speed on road =100 km/h, then

    sim_speed_factor=0 speed of the simulation 10 km/h (0.25x)

    sim_speed_factor=1 speed of the simulation 100 km/h (1x)

    sim_speed_factor=2 speed of the simulation 200 km/h (max)

    sim_speed_factor>2 speed of the simulation 200 km/h (max)

  • Quicksilver13

    Hi All

    Post #1 is from the GPS Passion forum, the author’s name is Berylus. It works, and looks useful so I thought I would share.

  • amida168

    Quicksilver13,

    Thanks for the info. Do you know what is the default for sim_speed_factor?

  • Quicksilver13

    Amida168,

    No I don’t, you would think that “sim_speed_factor=0” would be the default setting, and it looks like it is the least noticeable. It looks like a nice trick to use when testing out altered or mollified skins, and you want to speed things up and want the voice alerts. A script could be made to change the setting more easily, and it could be commented out if not wanted.

  • c230

    I think it’s possible to play voice alerts in fast flyover mode, as one of the skins I tried actually did this. May just involve adding one command. Also, my understanding is that fast flyover is 10x the normal speed, but it is amazing how many parameters can be added to SYS.TXT to tweak MioMap!

  • Quicksilver13

    This a link to a translated Russian web page with  nice explanations &

    graphics on the SYS.TXT  settings. It is for iGO 2006 Plus,

    but I believe that it also relates to the  Miomap 3.3 

    Sys.Txt  Info

    Don’t use the quick links on the web page, as they will break the

    translation, just scroll down the page to read the translated text.

  • amida168

    C230,

    Do you remember what skin lets you play voice alerts in fast flyover mode?

  • amida168

    Quicksilver13,

    Thanks for another great tip. It looks like we have more options to tweak.

  • c230

    Amida,

    No, I erased it last week from my Skins folder as other features didn’t behave. 🙁

  • Berylus

    Hi everyone.

    @ Quicksilver13 Ty.

    The best for your test flyover is =0

    indeed it work for any speedcam before the Mio of July 2007 after it don’t work I’m sorry.

    Nos it’s MIO who block a lot information.

    My best regards

  • Berylus

    U must use in your SYS.txt this:
    [debug]
    cache=2048
    And too this:
    [speedcam]
    usemio=-12,90,60,27
    My best regards

  • sveta

    Hello,
    I want to make that my miomap 3.3 can show me traffic jam or works on the road!!!
    If somebody know,I would be GRATEFUL!!!
    Thank you,
    Sveta

  • amida168

    sveta,
    You can buy TMC receiver in Europe to get traffic data, you also need to pay subscription to use the service. However, I don’t think you can get that in US.

  • Gabe

    (Didn’t know where to post this)

    How can I build my own car icon for the Mio C230, I did every I thought I should do to make it and it came allwrite the only thing is that when I replace the old icon with the new one I made after restarting the device when I clicked on the arrow to make the car appear it came up, but with white around it like the bitmap file. I would like to remove that white but don’t know how….any HELP!

    • amida168

      You should make your icon’s background transparent.

      • Gabe

        I tried with paint.net …but it didn’t work, that’s what I thought I had to do any suggestions

  • Gabe

    amida168:
    On the Quicksilver Reborn v1.3 Skin the car icon is a bmp file and it has a black background as it shows in the file but when you activate the icon on the device the black background doesn’t show. How was it created? I’ve been successful putting the background transparent with photoshop but i have problems it saves it as an abobe photoshop file and the device only accepts bmp file icons. I’ve tried a few things I found in google, but nothing has worked yet. Basically what I
    did was take a picture of my car amzda cx-9 and i want to create a bmp icon and replace it for the green car (reborn v1.3). I also tied the car icon on the Quicksilver Car loader 1.49b and it work to. I know there is something that i’m missing but i can’t find out what.

    • amida168

      Photoshop can save files as bitmap files.

  • Gabe

    Amida168:
    Would I have to do any changes here?

    You might now more than me, The alpha=30 what does it mean?

    • amida168

      alpha controls the transparency.

  • Gabe

    I pasted the ui_file comand but it didn’t paste.