Incompatible Software for Snow Leopard

Snow Leopard is out today. If you are considering upgrading to it, the first thing you need to know is that all the software for PowerPC are not working any more. There are some other Intel based software which are not compatible. For a complete list of those incompatible software, please visit this link.

[Update] There is an unofficial Wiki page about application compatibility under Snow Leopard. This list is much more comprehensive than the official page.

Be the first to comment

Leave a Reply

Social Widgets powered by

Advertisment ad adsense adlogger